Slow / Unresponsive HOK

Incident Report for Swapfiets

Resolved

The incident has been resolved
Posted Jul 04, 2025 - 10:26 CEST

Investigating

We received many complains regards to HOK being unresponsive and we are looking into the issue
Posted Jul 04, 2025 - 10:18 CEST
This incident affected: Hok/Smooth (HOK API Status, HOK Website Status).